two

Tuesday, April 7 2015

Unicomp != Model M
[12:53:06] matt [wronka.org]/Trip I would like to second the statement in this thread: https://www.physicsforums.com/threads/do-not-buy-a-unicomp-keyboard.613424/

I bought a Unicomp keyboard because my wife wanted a standard shape (e.g. not like my preferred Kinesis Advantage) keyboard and I wanted a mechanicle keyboard that would plug into a USB-only (non-PS/2) NUC. Immediately there were issues with keybaord not being recognized at all. That's ok, every company has some defective units, I sent it back and got the keyboard back fairly quickly (it now has a "repaired by Unicomp" sticker labeled June 2013 next to it's manufactured-on April 2013 sticker).

Two years after it was manufactured it started behaving oddly. The return consists of two pressure triggers, if the left side is the one you happen to hit, it triggers both the slash/pipe ('/') key and then the return key. My initial thought was that there was something physically connecting the two adjacent keys, but after removing the keys and examining the board superficially, everything seems fine. Trying with a different computer resulted in the same issue. A few days later, a few keys stopped responding entirely.

A keyboard failing within two years is sad; I'm currently typing on the same Kinesis keyboard I've used five-days a week for over seven years and functions flawlessly. I've got PS/2 and AT keyboards that still work from the 1980s.. Unicomp charges between $30-$90 for repair of a keyboard outside warranty (plus shipping) which seems like more hassle than it's worth considering this thing's already been back to them, and even then has the annoying habbit of not being recognized if plugged-in during computer boot.

Thursday, February 26 2015

Samsung's SmartHub
[15:55:31] matt [wronka.org]/Trip Two nights ago, my wife went to bed, and I tried to watch some Columbo on Netflix (I was up to the Great Santini, who sets up his own alibi through a fragile, technical, contrivance). We've only recently subscribed to Netflix since I've always been leary of the reliability of cloud services and rental subscriptions like this in general. It turns out the flakey Samsung implementation was more to blame.

This isn't abnormal. First off, the Samsung equipment (we own two of their TVs and one DVD player, all with essentially the same software) seem to arbitrarily forget WiFi passwords, which makes supporting them frustrating if not useless (they're all on the unsecured network now). Sometimes it fails to connect for a short period, and I need to just wait; that wasn't happening.

Obviously, there was a larger problem. I gave up and watched TopGear on my MythTV box instead, expecting whatever issue Samsung was having to resolve itself the next day. Why a box can't trust that it's on the Internet, or at least be optimistic about it once it's gotten an IP address, and a DNS server that resolves what it needs is an open question that I've tried to ask Samsung support (like the TV's software, I'm not optimistic for a response).

Yesterday while I was at work, I­ got a message from my wife, complaining about the DVD player not thinking it had Internet access. Obviously, she wanted to think it was a problem with our network—which is reasonable, given that's what the software said—but it turns out Samsung still didn't have their system up. It seems that there was some DNS hokeyness with their Akamai DSA settings. After a chain of CNAMEs (some of which included "china-" prefixes for some reason) eventually we got very short TTL addresses, which were not returning appropriate answers for the TV.

A Web search found somebody who *had* found an IP address that worked, also being served through Akamai DSA:
http://www.myce.com/news/smart-tv-mayhem-sony-samsung-users-central-servers-go-75137/

The resulting IP for www.samsung.com was 23.66.247.46; while you're setting-up your own DNS for your Samsung devices, I also suggest making ad.samsungadhub.com and rd.samsungadhub.com either fail or point to localhost since these are what send and track impressions for the annoying little piece of real estate in the top right corner.

I strongly discourage anyone from buying one of these devices (and apparently Sony devices) for these features, since they seem to be fragile. As I­ was trying to find information on the current outage (Samsung was not forthcoming and even mentioned on their support page of no known issues), I found references and news articles for outages regularly going back to 2013. It's clear Samsung doesn't treat this as production functionality.

More coverage today, after a couple days of this:
http://www.theregister.co.uk/2015/02/26/samsung_sony_tv_outage/

Tuesday, October 8 2013

Quec.li Updated: Now with Clusters!
[13:53:13] matt [wronka.org]/Trip For the first time in a long while, http://quec.li/ was updated last month, and after upgrading the database a little, now has clustering of articles enabled. Some work better than others, but as it gets more information from each feed, it should do better. There's a bit more I want to do with the UI (e.g. hide related stories from showing-up right next to each other), but in general, I'm quite happy with it. For example, on my dashboard now:

[The Register] Nuon, Tokai maintain six-race rivalry: No race records on the cards for 2013 Day Two of the World Solar Challenge has ended with only a handful of the vehicles reaching the checkpoint at Ti Tree, north of Alice Springs.?

Related
World Solar Challenge Underway [Slashdot]
All roads lead to Darwin ahead of solar challenge flag-fall [The Register]