Thursday, February 26 2015

Samsung's SmartHub
[15:55:31] matt [wronka.org]/Trip Two nights ago, my wife went to bed, and I tried to watch some Columbo on Netflix (I was up to the Great Santini, who sets up his own alibi through a fragile, technical, contrivance). We've only recently subscribed to Netflix since I've always been leary of the reliability of cloud services and rental subscriptions like this in general. It turns out the flakey Samsung implementation was more to blame.

This isn't abnormal. First off, the Samsung equipment (we own two of their TVs and one DVD player, all with essentially the same software) seem to arbitrarily forget WiFi passwords, which makes supporting them frustrating if not useless (they're all on the unsecured network now). Sometimes it fails to connect for a short period, and I need to just wait; that wasn't happening.

Obviously, there was a larger problem. I gave up and watched TopGear on my MythTV box instead, expecting whatever issue Samsung was having to resolve itself the next day. Why a box can't trust that it's on the Internet, or at least be optimistic about it once it's gotten an IP address, and a DNS server that resolves what it needs is an open question that I've tried to ask Samsung support (like the TV's software, I'm not optimistic for a response).

Yesterday while I was at work, I­ got a message from my wife, complaining about the DVD player not thinking it had Internet access. Obviously, she wanted to think it was a problem with our network—which is reasonable, given that's what the software said—but it turns out Samsung still didn't have their system up. It seems that there was some DNS hokeyness with their Akamai DSA settings. After a chain of CNAMEs (some of which included "china-" prefixes for some reason) eventually we got very short TTL addresses, which were not returning appropriate answers for the TV.

A Web search found somebody who *had* found an IP address that worked, also being served through Akamai DSA:

The resulting IP for www.samsung.com was; while you're setting-up your own DNS for your Samsung devices, I also suggest making ad.samsungadhub.com and rd.samsungadhub.com either fail or point to localhost since these are what send and track impressions for the annoying little piece of real estate in the top right corner.

I strongly discourage anyone from buying one of these devices (and apparently Sony devices) for these features, since they seem to be fragile. As I­ was trying to find information on the current outage (Samsung was not forthcoming and even mentioned on their support page of no known issues), I found references and news articles for outages regularly going back to 2013. It's clear Samsung doesn't treat this as production functionality.

More coverage today, after a couple days of this:

Sunday, December 7 2014

Lollipop/ART issues; Firefox Weave
[18:37:08] matt [wronka.org]/Psi.cor I've switched back to Android 4.4 (CM-11, "Kitkat"). The following were issues I found with Android 5.0 ("Lollipop"):
* fdroid repos don't work, which is annoying (https://gitlab.com/fdroid/fdroidclient/issues/111)
* some Activesync servers don't work—I've only seen this reported with Horde (and I had the issue with both 5.0 and 5.2; https://bugs.horde.org/ticket/13702)

Back on CM-11, using the ART runtime, Firefox Sync (Weave/"Deprecated") also fails, apparently with a Unicode string error. It works fine with Dalvik. I don't know if this would have been an issue on Lollipop as well which uses ART by default. I didn't look for a specific bug for this, but was surprised that this sync was still supported since it was supposed to go away several versions ago (https://bugs.horde.org/ticket/13702). Apparently work on making the new service easy to use by third parties is either hard or just not a priority—the whole issue seems to have been bungled and now everyone's stuck with a mess. (https://bugzilla.mozilla.org/show_bug.cgi?id=989756#c14)

I also missed some of the UI elements from CM-11, like the circular battery indicator (is this a theme added by CM?) The settings menu was also more usable on CM-11. In general, Lollipop seemed to waste space, although I had mixed feelings about the task switching interface (it did seem to show more options at once, but made the active surface a bit small on a phone screen). A lot of Lollipop was flat, and Apple-like, looking pretty without giving the user any indication of whether interfaces were scrollable or otherwise how to interact with the device.

Unlike other reports, I did not run into any issues with WiFi or battery life on Lollipop—in fact, both seemed to be at least as good if not more reliable than on CM-11 and CM-10.2 but I don't have any objective tests for that. Specifically, I thnk my worst battery behaviour was in part to K9 synching my mail, and I haven't set that back up.

Saturday, October 19 2013

Netgear ReadyNAS 6 Ultra
[16:38:13] matt [wronka.org]/Psi+ Periodically, my MythTV DVR has trouble pushing video to the front-ends. Jumping into the backend, it turns-out that this is because it's only pulling about 1MB/s from the Netgear Ready NAS 6 Ultra. I tried a variety of things, such as defragging the XFS filesystem I'm using on it, to no avail. Having a little more time this morning and nothing important to record, I spent a little more time looking at it, and realized that I was getting between 58ms and ~85ms ping times to the NAS which was directly connected over a 1Gb link (previously there was a combination 1Gb switch and WiFi AP in between I had blamed). 58ms is exceptoinally bad for this connection, and originally I thought I must have entered the address of my receiver connected via a WiFi link, but after tripple checking the receiver was actually < 2ms and the directly connected Ready NAS was magnitudes slower.

Rebooting the NAS immediately brought the latency back down to just over 0.2ms average and disk I/O back up to ~30MB/s, a huge change from before but a very dissapointing result. It looks like I ran into this last in early September from the NAS's log history.

Friday, June 7 2013

[13:09:24] matt [wronka.org]/Trip Adding #define OPENSSL_NO_ENGINE to wpa_supplicant fixed my WPA2 connection issues with Jelly Bean (4.2.2). Engine support in wpa_supplicant is ifdefed to only Android, and seemed like an obvious difference from a "normal" deploy. I'm not sure what the ramifications of this are, but would hazard a guess that possibly SIM-based authentication to WiFi might be affected?

Friday, May 11 2012

[03:50:56] matt [wronka.org]/Amabel The Asus WL-330N does seem to have a problem in that after a short time of use it stops transmitting its WiFi network, effectively dying even though its LEDs indicate everything is working. Sometimes it stays working for hours without an issue though, so it does not seem to be a necessarily consistent problem.

Thursday, March 1 2012

HP Touchpad
[16:17:55] matt [wronka.org]/Trip I've finally upgraded my Touchpad to WebOS 3.0.5 (I leanred with the 3.0.4 update to wait at least two weeks for the patches to be updated), and transferred Touchpads to my parents for Christmas.

Previously, I used the Touchpad tablet as a means for carrying a Debian computer around with me (using the Debian chroot). This allowed much greater flexibility, but the XServer didn't have ideal touch-support. It also completely lost the informational-messaging infrastucture built into WebOS.

Shortly before updating to 3.0.5 I started using my tablet more often for work business, synching with Exchange and configuring the mail client. I've also got it synchronizing with my personal schedule, and in general it's very good at those things.

Drawbacks to the standard usage:
a) no encryption. I wouldn't want to go through customs anywhere with my touchpad, especially not the US.
b) no PGP support in the mail client. The "flagged only" option doesn't seem to do what I expected (it's not showing anything; I'd expected it to sum-up all of the starred mailboxes).
c) Exchange synchronizing doesn't work at all unless you say to synchronize eMail. This seems odd, especially since my exchange system doesn't even synchronize eMail, but after telling the Touchpad to do this it works fine.
d) WiFi kept dropping out on an WPA2 network. Telling it to turn-off WiFi when asleep caused it to be smart enough to re-connect.

Friday, February 3 2012

[13:06:39] matt [wronka.org]/Merch My N900 usually cannot go a business day (we'll say 9 hours) on a charge; but I've had the SIM out and it's been on WiFi only for the last 9 hours and barely touched its reserves.

Thursday, February 2 2012

[14:01:14] matt [wronka.org]/Merch It is a bit odd that mobile (GSM) phones are smaller than SIP (WiFi) phones.

Wednesday, September 28 2011

[14:26:35] matt [wronka.org]/Merch After spending two nights in the Saray's basement, we've finally moved into the main compound which not only means that we can access WiFi from the room, but that we have a window!

Tuesday, May 17 2011

[18:13:01] matt [wronka.org]/Merch T-mobile doesn't have any data roaming on IWS, but at least Eastern Iowa Airport has open WiFi.

Friday, April 29 2011

Looking at Laptops
[14:48:02] matt [wronka.org]/Psi.dementia Newegg has a G4 MacBook for $200. I was almost tempted to get this now that there are reverse-engineered (open) drivers for the WiFi card, and I don't hae a personal laptop. However, the G4 comes with only 512MB RAM and is 5.4 lbs--which surprisingly Dell considers close to an "ultra-lightweight" (<5 lbs) which is laughable.

The best options on Newegg are an EeePC at $290 in beautiful Hot Pink, and an IdeaPad in normal Black for something over $300. Both have very similar specs, with the IdeaPad providing a 5-in-1 card reader (with no indication of what's supported, e.g. SD, MMC, SD-HD could be counted as three of them) but a lower quality webcam--as if there's really a difference.

But presumably all of these come with glary screens. Lenovo has basically removed the configuration options on their laptops (some let you configure accessories, but the hardware on the models I found the configurator for were fixed--others just had "buy it now" links).

Dell still has a configurator, which makes you select everything in turn before seeing the next option, and with a "talk to a representative now!" box that falls from the top of the screen instilling the feeling of a Regis Long Pause right after you give your Final Answer. I don't even know what I could have configured because it was so incredibly annoying.

Tuesday, February 22 2011

[14:47:57] matt [wronka.org]/Merch I let OSX do a software update, and now I don't have WiFi.

Sunday, February 20 2011

[04:54:25] matt [wronka.org]/Merch I'm done playing with T-Mobile's IPv6 APN for a while. The 3G IPv6 deb seems to cause problems switching from mobile data to WiFi.

Wednesday, August 18 2010

[19:33:57] matt [wronka.org]/Merch prox: If you find/build your WiFi Thermostat, let me know.

Tuesday, April 13 2010

Fancy Small Computers
[19:49:41] matt [wronka.org]/kerberos I remember a time, not so long ago, that it was difficult to find a small computer that was portable and had a long battery. The OQO looked intriguing, but it would continue to be vaporware for several years. The only thing I could find was the Fujitsu Lifebook P-series, which at the time was using the exciting new Transmeta Crusoe chips designed for energy efficiency. Unfortunately, even compared to the computers of the day, that laptop was slow.

These days "netbooks", much to the shagrin of Psion, are bountiful--often running on Intel's x86-compatible Atom processor, although increasingly running on ARM Snapdragons (supported by Maemo, Android, and Ubuntu Linux distributions among countless other variants). Jamie just got an Assus EeePC that's running Ubuntu; my mother has an Acer Aspire One running some MicroSoft version. I borrowed the EeePC and didn't want to give it back, it's really well done given a single-use mentality (the Netbook Remix variation of Ubuntu is very Mac-like).

The question I find myself pondering is what do I really want? I recently picked-up the Nokia N900 which runs at a decent clip, the Maemo 5 (Fremantle) interface is pretty snappy, and I've really gotten used to the touch interface for anything non-productive ("consumptive") tasks. It's actually a very amazing machine that in practice is very much like that P-2110 but smaller.

In the end there's a lot of small options, and they each have a different niche to fill--but I'm not sure how much overlap they all have. It could be that one covers too much of another's niche, making two distinct devices redundant. I can carry the N900 instead of the E61; but it doesn't replace the Neo when I need a small pocketable phone. I could carry the EeePC on trips where it would take-up less space than the MacBook, and still have a phenominal-for-a-laptop keyboard to compose messages or configure machines, or even do work albeit on a small screen. But what does that really get me? A slightly bigger screen (2") and a bigger keyboard, at the cost of another device--and one that doesn't have a ubiquitous Internet access at that.

If more areas had converted to municipal WiFi, it might be a different situation.